pay_android 1.0.6 icon indicating copy to clipboard operation
pay_android: ^1.0.6 copied to clipboard

A plug-in to add support for payments on the Android side of Flutter applications.

pub package

This is an implementation of the pay_platform_interface package for Android.

Usage #

With the pay plugin #

This package is the endorsed implementation of the pay plugin, so it gets automatically added to your dependencies when you add the pay package to your pubspec.yaml.

Using this package directly #

If you prefer to integrate or extend this package separately, add it as a dependency in your pubspec.yaml file as follows:

dependencies:
  pay_android: ^1.0.6

Now, you can use the buttons available for the supported payment providers and the methods exposed in the interface that this package uses to communicate with the native end.

RawGooglePayButton(
  style: GooglePayButtonStyle.black,
  type: GooglePayButtonType.pay);

Note: This is not an officially supported Google product.
2
likes
120
pub points
89%
popularity

Publisher

shield icon for verified publishersgoogle.dev

A plug-in to add support for payments on the Android side of Flutter applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_localizations, flutter_svg, pay_platform_interface

More

Packages that depend on pay_android