paulonia_utils 0.3.0
paulonia_utils: ^0.3.0 copied to clipboard

Flutter package with general functions, get environment, get device, get network status, etc.

5
likes
130 / 130
pub points
61 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 28 API elements (67.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:paulonia_utils/paulonia_utils.dart that imports:
  • package:paulonia_utils/paulonia_utils_mobile.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^3.0.23.0.63.0.6
device_info^2.0.02.0.22.0.2
flutterflutter0.0.00.0.0
ntp^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.4.00.4.0
connectivity_macos-0.2.00.2.0
connectivity_platform_interface-2.0.12.0.1
device_info_platform_interface-2.0.12.0.1
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
plugin_platform_interface-2.0.12.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

5
likes
130
pub points
61%
popularity

Publisher

paulonia.dev

Flutter package with general functions, get environment, get device, get network status, etc.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

connectivity, device_info, flutter, ntp

More

Packages that depend on paulonia_utils