path_parsing 0.2.1
path_parsing: ^0.2.1 copied to clipboard

A Dart library to help with SVG Path parsing and code generation. Used by Flutter SVG.

13
likes
110 / 130
pub points
100 %
popularity

We analyzed this package on May 6, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 49 API elements (6.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/path_parsing.dart:169:7

    ╷
169 │       return nextCommand;
    │       ^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/path_parsing.dart

INFO: DO use curly braces for all flow control structures.

lib/src/path_parsing.dart:237:9

    ╷
237 │         throw StateError('There must be at least one digit following the .');
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/path_parsing.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.3.01.3.01.3.0
vector_math^2.1.02.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.

13
likes
110
pub points
100%
popularity

Publisher

dnfield.dev

A Dart library to help with SVG Path parsing and code generation. Used by Flutter SVG.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta, vector_math

More

Packages that depend on path_parsing