particle_setup 0.4.0
particle_setup: ^0.4.0 copied to clipboard

Dart library to send commands to Particle IoT devices (https://www.particle.io/).

0
likes
80/ 130
pub points
1%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 80 out of 175 API elements (45.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:particle_setup/particle_setup.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^0.5.140.5.151.0.2
convert^2.1.12.1.13.0.1
json_annotation^3.0.03.1.14.1.0
pointycastle^1.0.21.0.23.3.4
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.5.14` on asn1lib does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions asn1lib to update the constraint.

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Dart 2.14.0.

0
likes
80
pub points
1%
popularity

Publisher

kirkeaton.ca

Dart library to send commands to Particle IoT devices (https://www.particle.io/).

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

asn1lib, convert, json_annotation, pointycastle

More

Packages that depend on particle_setup