parallax_widget 0.0.1 copy "parallax_widget: ^0.0.1" to clipboard
parallax_widget: ^0.0.1 copied to clipboard

Parallax widget for any your widget

0
likes
110/ 160
pub points
41%
popularity

We analyzed this package 15 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/nyahonk/parallax_widget was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: parallax_widget,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 12 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: gyro, gyro.getOrientation, gyro.getRotationMatrix, offset_calculated, offset_calculated.getOffset.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:parallax_widget/parallax_widget.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:parallax_widget/parallax_widget.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:parallax_widget/parallax_widget.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

WARNING: The operand can't be null, so the condition is always 'true'.

lib/gyro.dart:68:9

   ╷
68 │   if (R != null) {
   │         ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/gyro.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/gyro.dart:98:9

   ╷
98 │   if (I != null) {
   │         ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/gyro.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
sensors_plus ^1.3.2 1.4.1 5.0.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sensors_plus_platform_interface - 1.2.0 1.2.0
sensors_plus_web - 1.1.2 1.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.2` on sensors_plus does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sensors_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
110
pub points
41%
popularity

Publisher

unverified uploader

Parallax widget for any your widget

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

flutter, sensors_plus

More

Packages that depend on parallax_widget