palette 0.2.0+1
palette: ^0.2.0+1

Dart native js
Flutter Android iOS web

A package for creating, generating, and interfacing with color palettes. With support for constructing colors in the CMYK, HSI, HSL, HSP, HSB, LAB, RGB, and XYZ color spaces.

2
likes
90 / 110
pub points
71 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 95 out of 97 API elements (97.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/color_palette.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
color_models^0.3.0+10.3.0+10.3.0+1
highest_lowest^0.1.00.1.00.1.0
unique_list^0.1.2+10.1.2+10.1.2+1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
90
pub points
71%
popularity

Publisher

jamesalex.dev

A package for creating, generating, and interfacing with color palettes. With support for constructing colors in the CMYK, HSI, HSL, HSP, HSB, LAB, RGB, and XYZ color spaces.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

color_models, highest_lowest, unique_list

More

Packages that depend on palette