pagination_view 2.0.0 copy "pagination_view: ^2.0.0" to clipboard
pagination_view: ^2.0.0 copied to clipboard

Flutter package to simplify pagination of list of items from the internet.

161
likes
140/ 160
pub points
91%
popularity

We analyzed this package 35 hours ago, and awarded it 140 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/excogitatr/pagination_view/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 73 API elements (24.7 %) have documentation comments.

Some symbols that are missing documentation: bottom_loader, bottom_loader.BottomLoader, bottom_loader.BottomLoader.BottomLoader, empty_separator, empty_separator.EmptySeparator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'package:flutter/material.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/foundation.dart'.

lib/bloc/pagination_bloc.dart:5:8

  ╷
5 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bloc/pagination_bloc.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bloc ^7.0.0 7.2.1 8.1.4
flutter flutter 0.0.0 0.0.0
flutter_bloc ^7.0.1 7.3.3 8.1.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.0` on bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^7.0.1` on flutter_bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

161
likes
140
pub points
91%
popularity

Publisher

verified publishervedartm.com

Flutter package to simplify pagination of list of items from the internet.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

bloc, flutter, flutter_bloc

More

Packages that depend on pagination_view