packagekit 0.1.0
packagekit: ^0.1.0 copied to clipboard

Provides a client to connect to PackageKit - the service that enables installation and removal of software packages on Linux.

2
likes
100/ 130
pub points
0%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 390 API elements (3.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:packagekit/packagekit.dart that imports:
  • package:packagekit/src/packagekit_client.dart that imports:
  • package:dbus/dbus.dart that imports:
  • package:dbus/src/dbus_server.dart that imports:
  • package:dbus/src/dbus_properties.dart that imports:
  • package:dbus/src/dbus_object.dart that imports:
  • package:dbus/src/dbus_client.dart that imports:
  • package:dbus/src/dbus_peer.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dbus^0.5.00.5.60.6.6
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
meta-1.7.01.7.0
petitparser-4.4.04.4.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on dbus does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions dbus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

2
likes
100
pub points
0%
popularity

Publisher

canonical.com

Provides a client to connect to PackageKit - the service that enables installation and removal of software packages on Linux.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MPL-2.0 (LICENSE)

Dependencies

dbus

More

Packages that depend on packagekit