Pub Package

Provides a client to connect to PackageKit - the service that enables installation and removal of software packages on Linux.

import 'package:packagekit/packagekit.dart';

var client = PackageKitClient();
await client.connect();
print('Server version: ${client.versionMajor}.${client.versionMinor}.${client.versionMicro}');
print('Backend: ${client.backendDescription} (${client.backendName})');
print('Supported MIME types: ${client.mimeTypes.join(', ')}');
await client.close();

Contributing to packagekit.dart

We welcome contributions! See the contribution guide for more details.

Libraries

packagekit