package_info_plus_linux 2.0.0 copy "package_info_plus_linux: ^2.0.0" to clipboard
package_info_plus_linux: ^2.0.0 copied to clipboard

discontinuedreplaced by: package_info_plus
PlatformLinux

Linux implementation of the package_info_plus plugin

0
likes
130/ 160
pub points
81%
popularity

We analyzed this package 3 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://plus.fluttercommunity.dev/ was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: package_info_plus_linux,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: package_info_plus_linux.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 4 API elements (100.0 %) have documentation comments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:package_info_plus_linux/package_info_plus_linux.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:package_info_plus_linux/package_info_plus_linux.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:package_info_plus_linux/package_info_plus_linux.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:package_info_plus_linux/package_info_plus_linux.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:package_info_plus_linux/package_info_plus_linux.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
package_info_plus_platform_interface ^2.0.0 2.0.1 3.0.0
path ^1.8.0 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on package_info_plus_platform_interface does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions package_info_plus_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.