package_config 2.0.0
package_config: ^2.0.0 copied to clipboard

Support for working with Package Configuration files.

1
likes
90 / 130
pub points
99 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: Documenting package_config...
Initialized dartdoc with 48 libraries in 30.2 seconds
Generating docs for library package_config.package_config from package:package_config/package_config_types.dart...
Generating docs for library package_config.package_config from package:package_config/package_config.dart...
Documented 2 public libraries in 2.0 seconds
stderr:   warning: ambiguous reexport of package_config.PackageConfig, canonicalization candidates: (package_config.package_config, package_config.package_config) -> package_config.package_config (confidence 0.000)
    from package_config.PackageConfig: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:18:16)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
            Use {@canonicalFor package_config.PackageConfig} in the desired library's documentation to resolve
            the ambiguity and/or override dartdoc's decision, or structure your package 
            so the reexport is less ambiguous.  The symbol will still be referenced in 
            all candidates -- this only controls the location where it will be written 
            and which library will be displayed in navigation for the relevant pages.
            The flag --ambiguous-reexport-scorer-min-confidence allows you to set the
            threshold at which this warning will appear.
  warning: ambiguous reexport of package_config.LanguageVersion, canonicalization candidates: (package_config.package_config, package_config.package_config) -> package_config.package_config (confidence 0.000)
    from package_config.LanguageVersion: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:301:16)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
  warning: ambiguous reexport of package_config.Package, canonicalization candidates: (package_config.package_config, package_config.package_config) -> package_config.package_config (confidence 0.000)
    from package_config.Package: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:213:16)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
  warning: ambiguous reexport of package_config.InvalidLanguageVersion, canonicalization candidates: (package_config.package_config, package_config.package_config) -> package_config.package_config (confidence 0.000)
    from package_config.InvalidLanguageVersion: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:378:16)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
        package_config.package_config: 0.2600 - name is long (+0.01000), element location shares parts with name (+0.2500)
  warning: ambiguous reexport of errors.PackageConfigError, canonicalization candidates: (package_config.package_config, package_config.package_config) -> package_config.package_config (confidence 0.000)
    from errors.PackageConfigError: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/errors.dart:9:16)
        package_config.package_config: 0.2100 - name is long (+0.01000), element location shares parts with name (+0.2000)
        package_config.package_config: 0.2100 - name is long (+0.01000), element location shares parts with name (+0.2000)
  warning: unresolved doc reference [false], from package_config.package_config.findPackageConfig: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/package_config.dart:115:24)
  warning: unresolved doc reference [false], from package_config.package_config.findPackageConfigUri: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/package_config.dart:159:24)
  error: failed to write file at: package_config.package_config/package_config.package_config-library.html
    for symbol package_config.package_config: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/package_config.dart:10:9)
    conflicting with file already generated by package_config.package_config: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/package_config_types.dart:7:9)
            Dartdoc generates a path and filename to write to for each symbol.
            package_config.package_config conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: unresolved doc reference [Package.rootUri], from package_config.package_config.PackageConfig.PackageConfig: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:53:11)
  warning: unresolved doc reference [Package.rootUri], from package_config.package_config.PackageConfig.packageOf: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:174:12)
  warning: unresolved doc reference [configuration], from package_config.package_config.PackageConfig.parseJson: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:113:24)
  warning: unresolved doc reference [rootUri], from package_config.package_config.Package.root: (file:///tmp/pub-dartlang-dartdocYOTVIY/pkg/lib/src/package_config.dart:252:11)
Found 11 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:225:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:21:19)
<asynchronous suspension>

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:package_config/package_config.dart that imports:
  • package:package_config/src/package_config_io.dart that imports:
  • package:package_config/src/util_io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
path^1.8.01.8.01.8.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.