oscilloscope 0.2.0+1 copy "oscilloscope: ^0.2.0+1" to clipboard
oscilloscope: ^0.2.0+1 copied to clipboard

A graphical widget that can be used to display a dataset similar to an oscilloscope display

17
likes
120/ 140
pub points
81%
popularity

We analyzed this package 47 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 14 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: oscilloscope, oscilloscope.Oscilloscope.backgroundColor, oscilloscope.Oscilloscope.dataSet, oscilloscope.Oscilloscope.margin, oscilloscope.Oscilloscope.onNewViewport.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: A value for optional parameter 'xScale' isn't ever given.

lib/oscilloscope.dart:105:12

    ╷
105 │       this.xScale = 1.0,
    │            ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/oscilloscope.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cupertino_icons ^1.0.2 1.0.6 1.0.6
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

17
likes
120
pub points
81%
popularity

Publisher

verified publisherspiralarm.uk

A graphical widget that can be used to display a dataset similar to an oscilloscope display

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

cupertino_icons, flutter

More

Packages that depend on oscilloscope