ory_client 1.6.2 copy "ory_client: ^1.6.2" to clipboard
ory_client: ^1.6.2 copied to clipboard

OpenAPI API client for Ory Network, Ory's web-scale API for identity and access control.

11
likes
125/ 160
pub points
78%
popularity

We analyzed this package 20 hours ago, and awarded it 125 pub points (of a possible 160):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. Check out the Dart conventions for Maintaining a package changelog.

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3012 out of 6123 API elements (49.2 %) have documentation comments.

Some symbols that are missing documentation: ory_client, ory_client.AcceptOAuth2ConsentRequest.context, ory_client.AcceptOAuth2ConsentRequest.grantAccessTokenAudience, ory_client.AcceptOAuth2ConsentRequest.grantScope, ory_client.AcceptOAuth2ConsentRequest.handledAt.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 721 issues. Showing the first 2:

WARNING: Unused import: 'package:ory_client/src/model/error_generic.dart'.

lib/src/api/courier_api.dart:13:8

   ╷
13 │ import 'package:ory_client/src/model/error_generic.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/api/courier_api.dart

WARNING: Unused import: 'package:ory_client/src/model/error_generic.dart'.

lib/src/api/events_api.dart:11:8

   ╷
11 │ import 'package:ory_client/src/model/error_generic.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/api/events_api.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
built_collection >=5.1.1 <6.0.0 5.1.1 5.1.1
built_value >=8.4.0 <9.0.0 8.9.2 8.9.2
dio ^5.0.0 5.4.3+1 5.4.3+1
one_of >=1.5.0 <2.0.0 1.5.0 1.5.0
one_of_serializer >=1.5.0 <2.0.0 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
collection - 1.19.0 1.19.0
fixnum - 1.1.0 1.1.0
http_parser - 4.1.0 4.1.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

11
likes
125
pub points
78%
popularity

Publisher

verified publisherory.sh

OpenAPI API client for Ory Network, Ory&#39;s web-scale API for identity and access control.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

built_collection, built_value, dio, one_of, one_of_serializer

More

Packages that depend on ory_client