opengl 0.5.0
opengl: ^0.5.0 copied to clipboard

OpenGL 4.6 FFI bindings for Dart. Supports Linux, macOS and Windows.

18
likes
100/ 130
pub points
46%
popularity

We analyzed this package on Oct 13, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-20T10:43:39.598487] Starting...
Documenting opengl...
Initialized dartdoc with 47 libraries in 34.6 seconds
Generating docs for library opengl from package:opengl/opengl.dart...

stderr: Unhandled exception:
DocumentationTooBigException: Reached 2147483648 bytes in the output directory.
#0      PubResourceProvider._aboutToWriteBytes (package:pub_dartdoc/src/pub_hooks.dart:76:7)
#1      _File.writeAsBytesSync (package:pub_dartdoc/src/pub_hooks.dart:180:15)
#2      _File.writeAsStringSync (package:pub_dartdoc/src/pub_hooks.dart:186:5)
#3      DartdocFileWriter.write (package:dartdoc/dartdoc.dart:85:10)
#4      DartdocGeneratorBackend.write (package:dartdoc/src/generator/dartdoc_generator_backend.dart:101:12)
#5      DartdocGeneratorBackend.generateTypeDef (package:dartdoc/src/generator/dartdoc_generator_backend.dart:256:5)
#6      GeneratorFrontEnd._generateDocs (package:dartdoc/src/generator/generator_frontend.dart:261:29)
#7      GeneratorFrontEnd.generate (package:dartdoc/src/generator/generator_frontend.dart:21:5)
#8      Dartdoc.generateDocsBase (package:dartdoc/dartdoc.dart:196:21)
<asynchronous suspension>
#9      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:233:24)
<asynchronous suspension>
#10     main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:opengl/opengl.dart that imports:
  • package:opengl/src/opengl_init.dart that imports:
  • package:opengl/src/opengl_library.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/utf16.dart that imports:
  • dart:ffi
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/opengl_library.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^1.1.01.1.21.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

18
likes
100
pub points
46%
popularity

OpenGL 4.6 FFI bindings for Dart. Supports Linux, macOS and Windows.

Repository (GitLab)
View/report issues

License

Apache-2.0 (LICENSE)

Dependencies

ffi

More

Packages that depend on opengl