openfoodfacts 0.3.15+3
openfoodfacts: ^0.3.15+3 copied to clipboard

Dart package for the Open Food Facts API, a food products database made by everyone, for everyone.

27
likes
90 / 130
pub points
80 %
popularity

We analyzed this package on May 7, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 45 out of 1615 API elements (2.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
async_loader^0.1.20.1.20.1.2
http^0.12.20.12.20.13.3
image^2.1.192.1.193.0.2
json_annotation^3.1.13.1.14.0.1
path^1.7.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
flutter-0.0.00.0.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
petitparser-3.1.04.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-4.5.15.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^2.1.19` on image does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.5 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

27
likes
90
pub points
80%
popularity

Dart package for the Open Food Facts API, a food products database made by everyone, for everyone.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

a.schaefer@playsys.de
primael@reefind.com
peter.w.v.jorgensen@gmail.com
stephane@openfoodfacts.org

License

Apache 2.0 (LICENSE)

Dependencies

async_loader, http, image, json_annotation, path

More

Packages that depend on openfoodfacts