open_graph_parser 0.0.6

Dart native js
Flutter Android iOS web

An open graph parser for Dart.

1
likes
75 / 110
pub points
68 %
popularity

We analyzed this package on Sep 23, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 5 API elements (20.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Use isEmpty instead of length

lib/open_graph_parser.dart:32:37

   ╷
32 │           if (ogTagValue == null || ogTagValue.length == 0) {
   │                                     ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/open_graph_parser.dart

INFO: Use isNotEmpty instead of length

lib/open_graph_parser.dart:52:11

   ╷
52 │       if (images.length > 0) {
   │           ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/open_graph_parser.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
html^0.13.3+30.13.4+20.14.0+3
http>=0.11.3+17 <=0.12.00.12.00.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
csslib-0.15.00.16.2
http_parser-3.1.43.1.4
meta-1.2.31.2.3
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
utf-0.9.0+50.9.0+5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3+3` on html does not support the latest published version `0.14.0+3`

pubspec.yaml:10:9

   ╷
10 │   html: ^0.13.3+3
   │         ^^^^^^^^^
   ╵
The constraint `>=0.11.3+17 <=0.12.0` on http does not support the latest published version `0.12.2`

pubspec.yaml:9:9

  ╷
9 │   http: ">=0.11.3+17 <= 0.12.0"
  │         ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs