open_camera 0.0.5
open_camera: ^0.0.5 copied to clipboard

Open Camera is a flutter project that provides a complete widget for shooting and recording videos.

5
likes
80/ 130
pub points
34%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 17 API elements (11.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:open_camera/open_camera.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
auto_orientation^1.0.51.0.62.1.0
camera^0.5.4+20.5.8+170.9.4+5
flutterflutter0.0.00.0.0
flutter_image_compress^0.6.30.6.81.1.0
image_gallery_saver^1.2.21.7.11.7.1
native_device_orientation^0.2.00.2.01.0.0
path_provider^1.1.21.6.282.0.7
permission_handler^3.2.03.3.08.3.0
photo_view^0.6.00.6.00.13.0
video_player^0.10.2+10.10.12+52.2.7
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.0.5` on auto_orientation does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions auto_orientation to update the constraint.

The constraint `^0.5.4+2` on camera does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.