opayhttpmodule: ^1.0.0+2 copied to clipboard
We analyzed this package on Apr 22, 2021, and awarded it 55 pub points (of a possible 110):
0/10 points: Provide a valid
Homepage URL doesn't exist.
At the time of the analysis
https://www.opay.com was unreachable.
The package description is too short.
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
5/5 points: Provide a valid
0/5 points: Provide a valid
`CHANGELOG.md` contains too many non-ASCII characters.
The site uses English as its primary language. The content of
CHANGELOG.md in your package should primarily contain characters used in English.
0/10 points: Package has an example
No example found.
See package layout guidelines on how to add an example.
0/10 points: 20% or more of the public API has dartdoc comments
- 6 out of 43 API elements (14.0 %) have documentation comments.
Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.
20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)
20/30 points: code has no errors, warnings, lints, or formatting issues
Found 6 issues. Showing the first 2:
INFO: Name non-constant identifiers using lowerCamelCase.
╷ 33 │ String version_name; │ ^^^^^^^^^^^^ ╵
To reproduce make sure you are using pedantic and run
flutter analyze lib/http/Demo.dart
lib/http/Demo.dart is not formatted according to dartfmt
To format your files run:
dartfmt -w .
0/10 points: All of the package dependencies are supported in the latest version
To reproduce run
pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.
Found 3 issues. Showing the first 2:
The constraint `^0.1.3` on cupertino_icons does not support the stable version `1.0.0`.
dart pub upgrade --major-versions cupertino_icons to update the constraint.
The constraint `^3.0.10` on dio does not support the stable version `4.0.0`, that was published 24 days ago.
When dio is 30 days old, this package will no longer be awarded points in this category.
dart pub upgrade --major-versions dio to update the constraint.
10/10 points: Package supports latest stable Dart and Flutter SDKs