omnisaude_chatbot 0.0.8+2 icon indicating copy to clipboard operation
omnisaude_chatbot: ^0.0.8+2 copied to clipboard

Pacote de integração do chatbot da Omnisaude para aplicativos móveis.

2
likes
30/ 130
pub points
31%
popularity

We analyzed this package 5 hours ago, and awarded it 30 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://leonardobido.me/ was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +73 ms] executing: uname -m
[  +41 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +8 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +5 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] ee4e09cce01d6f2d7f4baebd247fde02e5008851
[        ] executing: [/tool/stable/flutter/] git tag --points-at ee4e09cce01d6f2d7f4baebd247fde02e5008851
[  +17 ms] Exit code 0 from: git tag --points-at ee4e09cce01d6f2d7f4baebd247fde02e5008851
[        ] 3.0.0
[  +11 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +5 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +58 ms] Unable to locate an Android SDK.
[   +4 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +3 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +58 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +53 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/dart __deprecated_pub upgrade --verbose
MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envIEOSBY/pub-cache-dirBTFQJE/log/pub_log.txt.
[+3267 ms] "flutter pub" took 3,398ms.
[   +4 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[   +1 ms] exiting with code 1

stderr: FINE: Pub 2.17.0
SLVR: fact: omnisaude_chatbot is 0.0.8+2
SLVR: derived: omnisaude_chatbot
SLVR: fact: omnisaude_chatbot depends on advance_pdf_viewer ^1.2.2
SLVR: fact: omnisaude_chatbot depends on cached_network_image ^2.5.0
SLVR: fact: omnisaude_chatbot depends on carousel_slider ^3.0.0
SLVR: fact: omnisaude_chatbot depends on dio ^3.0.10
SLVR: fact: omnisaude_chatbot depends on file_picker ^2.1.5+1
SLVR: fact: omnisaude_chatbot depends on flutter from sdk
SLVR: fact: omnisaude_chatbot depends on flutter_cached_pdfview ^0.3.5
SLVR: fact: omnisaude_chatbot depends on flutter_datetime_picker ^1.4.0
SLVR: fact: omnisaude_chatbot depends on flutter_html ^1.2.0
SLVR: fact: omnisaude_chatbot depends on flutter_localizations from sdk
SLVR: fact: omnisaude_chatbot depends on flutter_modular ^2.0.1
SLVR: fact: omnisaude_chatbot depends on flutter_staggered_grid_view ^0.3.3
SLVR: fact: omnisaude_chatbot depends on image_cropper ^1.3.1
SLVR: fact: omnisaude_chatbot depends on image_picker ^0.6.7+22
SLVR: fact: omnisaude_chatbot depends on intl ^0.16.1
SLVR: fact: omnisaude_chatbot depends on mask_text_input_formatter ^1.2.1
SLVR: fact: omnisaude_chatbot depends on mime ^0.9.7
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:281:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:229:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:94:3)
           <asynchronous suspension>



icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 2145 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/cupertino.dart'.

lib/app/chatbot/choose_widget_to_render/choose_widget_to_render_widget.dart:1:8

  ╷
1 │ import 'package:flutter/cupertino.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/app/chatbot/choose_widget_to_render/choose_widget_to_render_widget.dart

ERROR: Target of URI doesn't exist: 'package:flutter/material.dart'.

lib/app/chatbot/choose_widget_to_render/choose_widget_to_render_widget.dart:2:8

  ╷
2 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/app/chatbot/choose_widget_to_render/choose_widget_to_render_widget.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because every version of flutter_localizations from sdk depends on intl 0.17.0 and omnisaude_chatbot depends on intl ^0.16.1, flutter_localizations from sdk is forbidden.
So, because omnisaude_chatbot depends on flutter_localizations from sdk, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.