okdio_generator 0.2.3
okdio_generator: ^0.2.3 copied to clipboard

okdio is an dio client generator using source_gen and inspired from retrofit based on chopper

0
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:okdio_generator/okdio_generator.dart that imports:
  • package:okdio_generator/src/generator.dart that imports:
  • package:okdio/okdio.dart that imports:
  • package:okdio/src/response.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 96 issues. Showing the first 2:

INFO: Unused import: 'dart:math'.

lib/src/generator.dart:3:8

  ╷
3 │ import 'dart:math';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generator.dart

INFO: Unused import: 'dart:mirrors'.

lib/src/generator.dart:4:8

  ╷
4 │ import 'dart:mirrors';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/generator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.40.0 <0.42.00.41.21.5.0
build^1.2.21.6.22.0.1
built_collection^5.0.05.0.05.0.0
code_builder^3.6.03.7.04.0.0
dart_style^1.3.71.3.122.0.1
logging^0.11.00.11.41.0.1
meta^1.2.21.3.01.3.0
okdio^0.1.40.1.60.1.6
source_gen^0.9.7+10.9.10+31.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
args-2.1.02.1.0
async-2.6.12.6.1
built_mirrors-0.11.00.13.0
built_value-8.0.68.0.6
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dio-3.0.104.0.0
dson-0.16.00.18.0
file-6.1.06.1.0
fixnum-1.0.01.0.0
glob-2.0.12.0.1
http_parser-3.1.44.0.0
matcher-0.12.100.12.10
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-2.0.02.0.0
rxdart-0.24.10.27.0
serializable-0.12.00.14.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `>=0.40.0 <0.42.0` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
60
pub points
0%
popularity

okdio is an dio client generator using source_gen and inspired from retrofit based on chopper

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

cjasq1@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, built_collection, code_builder, dart_style, logging, meta, okdio, source_gen

More

Packages that depend on okdio_generator