okdio_generator 0.0.2

  • Readme
  • Changelog
  • Installing
  • 39

Chopper is an http client generator using source_gen and inspired by Retrofit.

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  okdio_generator: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:okdio_generator/okdio_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: other

Primary library: package:okdio_generator/okdio_generator.dart with components: io, build, mirrors.

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/generator.dart. (-7.71 points)

Analysis of lib/src/generator.dart reported 16 hints, including:

line 117 col 11: The value of the local variable 'responseInnerType' isn't used.

line 258 col 9: DO use curly braces for all flow control structures.

line 425 col 25: Use isNotEmpty instead of length

line 459 col 3: The declaration '_mkJsonType2' isn't referenced.

line 463 col 25: Use isNotEmpty instead of length

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (analyzer, built_collection).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and okdio_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
analyzer ^0.34.0 0.34.3 0.39.0
build ^1.0.0 1.1.0 1.2.0
built_collection ^3.1.3 3.1.3 4.2.2
code_builder ^3.0.0 3.2.0
dart_style ^1.0.10 1.2.3 1.3.2
logging ^0.11.0 0.11.3+2
meta ^1.1.6 1.1.7
okdio ^0.0.2 0.0.2
source_gen ^0.9.0 0.9.4+1 0.9.4+5
Transitive dependencies
args 1.5.2
async 2.4.0
built_mirrors_core 0.10.4 0.10.6
built_value 6.7.1
charcode 1.1.2
collection 1.14.12
convert 2.1.1
cookie_jar 1.0.1
crypto 2.1.3
csslib 0.16.1
dio 2.2.2 3.0.3
dson 0.15.5 0.16.0
dson_core 0.15.4 0.15.6
fixnum 0.10.9
front_end 0.1.9+1 0.1.28
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
kernel 0.3.9+1 0.3.28
matcher 0.12.6
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pedantic 1.8.0+1
plugin 0.2.0+3
pub_semver 1.4.2
quiver 2.0.5
rxdart 0.22.4
serializable_core 0.11.2+1 0.11.3
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.2.0