ocg_gallery 0.0.7 icon indicating copy to clipboard operation
ocg_gallery: ^0.0.7 copied to clipboard

A new Flutter package project.

0
likes
40/ 130
pub points
0%
popularity

We analyzed this package 6 hours ago, and awarded it 40 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 34 API elements (11.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ocg_gallery/ocg_gallery.dart that imports:
  • package:ocg_gallery/src/utils/gallery.dart that imports:
  • package:video_thumbnail/video_thumbnail.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:ocg_gallery/ocg_gallery.dart that imports:
  • package:ocg_gallery/src/utils/gallery.dart that imports:
  • package:video_thumbnail/video_thumbnail.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:ocg_gallery/ocg_gallery.dart that imports:
  • package:ocg_gallery/src/utils/gallery.dart that imports:
  • package:video_thumbnail/video_thumbnail.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:ocg_gallery/ocg_gallery.dart that imports:
  • package:ocg_gallery/src/utils/gallery.dart that imports:
  • package:video_thumbnail/video_thumbnail.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

ERROR: Instance member 'cropImage' can't be accessed using static access.

lib/src/utils/gallery.dart:105:36

    ╷
105 │     File temp = await ImageCropper.cropImage(sourcePath: file.path);
    │                                    ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/gallery.dart

INFO: This function has a return type of 'FutureOr

lib/src/utils/gallery.dart:52:40

   ╷
52 │   static Future<AppResponse<FileData>> pickFile() async {
   │                                        ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/utils/gallery.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
image_cropper^1.4.01.5.12.0.3
image_picker^0.6.7+220.6.7+220.8.5+3
ocg_app^0.0.520.0.560.0.56
path_provider^2.0.12.0.102.0.10
photo_view^0.9.20.9.20.13.0
video_player^1.0.11.0.12.4.2
video_thumbnail^0.2.5+10.2.5+10.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
auth_header-2.1.43.0.1
bot_toast-3.0.54.0.1
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.1
crypto-2.1.53.0.2
equatable-1.2.62.0.3
ffi-1.2.11.2.1
file-6.1.26.1.2
flutter_plugin_android_lifecycle-1.0.112.0.6
flutter_web_plugins-0.0.00.0.0
get_it-5.0.67.2.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.5.0
intl-0.16.10.17.0
jaguar_jwt-2.1.63.0.0
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.7.0
path-1.8.11.8.1
path_provider_android-2.0.92.0.14
path_provider_ios-2.0.92.0.9
path_provider_linux-2.1.62.1.6
path_provider_macos-2.0.32.0.6
path_provider_platform_interface-2.0.02.0.4
path_provider_windows-2.0.62.0.6
pedantic-1.11.11.11.1
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
smooth_page_indicator-0.2.31.0.0+2
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
url_launcher-5.7.106.1.2
url_launcher_linux-0.0.1+43.0.1
url_launcher_macos-0.0.1+93.0.1
url_launcher_platform_interface-1.0.92.0.5
url_launcher_web-0.1.5+32.0.11
url_launcher_windows-0.0.1+33.0.1
uuid-2.2.23.0.6
vector_math-2.1.22.1.2
video_player_platform_interface-2.2.05.1.2
video_player_web-0.1.4+12.0.10
win32-2.6.12.6.1
xdg_directories-0.2.0+10.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^1.4.0` on image_cropper does not support the stable version `2.0.0`, that was published 20 days ago.

When image_cropper is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions image_cropper to update the constraint.

The constraint `^0.6.7+22` on image_picker does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions image_picker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.

0
likes
40
pub points
0%
popularity

Publisher

unverified uploader

A new Flutter package project.

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter, image_cropper, image_picker, ocg_app, path_provider, photo_view, video_player, video_thumbnail

More

Packages that depend on ocg_gallery