numda 0.0.3

Dart native js
Flutter Android iOS web

numeric library for dart (just like numpy)

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 19 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Unused import: 'package:sprintf/sprintf.dart'.

lib/complex.dart:2:8

  ╷
2 │ import 'package:sprintf/sprintf.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/complex.dart

INFO: Don't type annotate initializing formals.

lib/complex.dart:7:11

  ╷
7 │   Complex(double this.a,double this.b);
  │           ^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/complex.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
sprintf^4.0.24.1.05.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.2` on sprintf does not support the latest published version `5.0.0`

pubspec.yaml:9:12

  ╷
9 │   sprintf: ^4.0.2
  │            ^^^^^^
  ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

numeric library for dart (just like numpy)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ccckmit@gmail.com

License

BSD (LICENSE)

Dependencies

sprintf

More

Packages that depend on numda