ntlm 2.0.1 copy "ntlm: ^2.0.1" to clipboard
ntlm: ^2.0.1 copied to clipboard

Library for making HTTP requests that require NTLM authentication

7
likes
115/ 140
pub points
81%
popularity

We analyzed this package 43 hours ago, and awarded it 115 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:64:1

   ╷
64 │ <a href="http://davenport.sourceforge.net/ntlm.html#appendixD">this</a> page.</p>
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Unlicense.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 42 API elements (59.5 %) have documentation comments.

Some symbols that are missing documentation: ntlm.NTLMClient, ntlm.NTLMClient.multipart, ntlm.Type2Message.negotiateFlags, ntlm.Type2Message.reserved, ntlm.Type2Message.serverChallenge.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

INFO: The variable name 'FACTORY_CONFIG' isn't a lowerCamelCase identifier.

lib/src/des/des.dart:10:30

   ╷
10 │   static final FactoryConfig FACTORY_CONFIG =
   │                              ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/des/des.dart

INFO: The variable name 'SP1' isn't a lowerCamelCase identifier.

lib/src/des/des_constants.dart:146:7

    ╷
146 │ final SP1 = [
    │       ^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/des/des_constants.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fixnum ^1.0.0 1.1.0 1.1.0
http ^0.13.1 0.13.6 1.2.1
pointycastle ^3.0.1 3.9.0 3.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.1` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

7
likes
115
pub points
81%
popularity

Publisher

verified publishermrbbot.dev

Library for making HTTP requests that require NTLM authentication

Repository (GitHub)
View/report issues

Documentation

API reference

License

Unlicense (LICENSE)

Dependencies

fixnum, http, pointycastle

More

Packages that depend on ntlm