ns_google_map_location_picker 0.0.3+1

Flutter Android iOS

A Flutter plugin which allows user to pick location using Google Maps.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Oct 24, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 302 API elements (4.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:ns_google_map_location_picker/common_widgets/maps_widget.dart that imports:
  • package:ns_google_map_location_picker/services/google_maps_service.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:ns_google_map_location_picker/common_widgets/maps_widget.dart that imports:
  • package:ns_google_map_location_picker/services/google_maps_service.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:ns_google_map_location_picker/common_widgets/maps_widget.dart that imports:
  • package:ns_google_map_location_picker/services/google_maps_service.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:ns_google_map_location_picker/common_widgets/maps_widget.dart that imports:
  • package:ns_google_map_location_picker/services/google_maps_service.dart that imports:
  • package:google_maps_flutter/google_maps_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: 'getCurrentPosition' is deprecated and shouldn't be used. Call Geolocator.getCurrentPosition() instead.This feature was deprecated after 6.0.0+4..

lib/screens/location_picker.dart:92:24

   ╷
92 │       position = await getCurrentPosition(desiredAccuracy: LocationAccuracy.high);
   │                        ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/screens/location_picker.dart

lib/common_widgets/maps_widget.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_layout^1.0.7+21.0.7+21.0.7+2
dio^3.0.103.0.103.0.10
flutterflutter0.0.00.0.0
flutter_screenutil^3.0.23.2.03.2.0
geolocator^6.0.0+46.1.16.1.1
geopoint^0.7.10.7.10.7.1
google_maps_flutter^0.5.320.5.331.0.3
intl^0.16.10.16.10.16.1
screen_loader^2.0.12.0.12.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.0.51.0.5
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
console_log_handler-1.1.61.1.6
extra_pedantic-1.2.01.2.0
flutter_plugin_android_lifecycle-1.0.111.0.11
geolocator_platform_interface-1.0.51.0.5
google_maps_flutter_platform_interface-1.0.41.0.4
http_parser-3.1.43.1.4
latlong-0.6.10.6.1
logging-0.11.40.11.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
path-1.7.01.8.0-nullsafety.2
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
sky_engine-0.0.990.0.99
slugify2-0.2.10.2.1
source_span-1.7.01.8.0-nullsafety.3
stream_transform-1.2.01.2.0
string_scanner-1.0.51.1.0-nullsafety.2
term_glyph-1.1.01.2.0-nullsafety.2
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
validate-1.7.01.7.0
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.32` on google_maps_flutter does not support the latest published version `1.0.3`

pubspec.yaml:23:24

   ╷
23 │   google_maps_flutter: ^0.5.32
   │                        ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs