notustohtml 0.0.8 icon indicating copy to clipboard operation
notustohtml: ^0.0.8 copied to clipboard

Convert the Notus document format to an HTML representation.

16
likes
90/ 130
pub points
82%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 5 API elements (40.0 %) have documentation comments.
icon indicating section status
Support multiple platforms
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 2 possible platforms (native, js)

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/notustohtml.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
html^0.14.00.14.0+40.15.0
notus^0.1.50.1.50.1.5
quill_delta^1.0.21.1.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
csslib-0.16.20.17.1
meta-1.7.01.7.0
path-1.8.11.8.1
quiver_hashcode-2.0.03.0.0+1
source_span-1.8.21.8.2
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.14.0` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

The constraint `^1.0.2` on quill_delta does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions quill_delta to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

16
likes
90
pub points
82%
popularity

Publisher

shield icon for verified publisherswrenn.me

Convert the Notus document format to an HTML representation.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

html, notus, quill_delta

More

Packages that depend on notustohtml