notepad_core_web 1.4.2
notepad_core_web: ^1.4.2 copied to clipboard

Flutter plugin web implementation for connect & operate on BLE peripheral.

0
likes
50 / 110
pub points
26 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 74 API elements (2.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:notepad_core_web/notepad_core_web.dart that declares support for platforms: Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/js_facade.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/notepad_core_js.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.13.0.0
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
js^0.6.1+10.6.30.6.3
notepad_core_platform_interface^1.4.21.4.21.4.2
platform_detect^1.4.01.4.01.4.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
meta-1.3.01.3.0
plugin_platform_interface-1.0.32.0.0
pub_semver-1.4.42.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.