node_interop 2.0.0
node_interop: ^2.0.0 copied to clipboard

Provides Dart bindings and utility functions for core Node.js modules.

23
likes
105 / 130
pub points
97 %
popularity

We analyzed this package on Apr 12, 2021, and awarded it 105 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:109:1

    ╷
109 │ <a href="http://github.com/pulyaevskiy/node-interop/issues/new">issue tracker</a>.</p>
    │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 199 out of 1266 API elements (15.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:node_interop/node_interop.dart that imports:
  • package:node_interop/node.dart that imports:
  • package:node_interop/timers.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js^0.6.10.6.30.6.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Dart 2.12.2.

23
likes
105
pub points
97%
popularity

Provides Dart bindings and utility functions for core Node.js modules.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

anatoly.pulyaevskiy@gmail.com
nweiz@google.com
awjin@google.com
jathak@google.com

License

BSD (LICENSE)

Dependencies

js

More

Packages that depend on node_interop