nhost_gql_links 4.0.5 copy "nhost_gql_links: ^4.0.5" to clipboard
nhost_gql_links: ^4.0.5 copied to clipboard

Constructs GraphQL links for use with graphql and ferry packages

2
likes
140/ 140
pub points
5%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 6 API elements (83.3 %) have documentation comments.

Some symbols that are missing documentation: nhost_gql_links.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
gql ^1.0.0 1.0.0+1 1.0.0+1
gql_exec ^1.0.0 1.0.0+1 1.0.0+1
gql_http_link ^1.0.1 1.0.1+1 1.0.1+1
gql_link ^1.0.0 1.0.0+1 1.0.0+1
gql_websocket_link ^2.0.1 2.0.1 2.0.1
http ^1.1.0 1.2.1 1.2.1
logging ^1.1.0 1.2.0 1.2.0
meta ^1.7.0 1.14.0 1.14.0
nhost_sdk ^5.3.0 5.3.0 5.3.0
web_socket_channel ^2.2.0 2.4.5 2.4.5
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http_parser - 4.0.2 4.0.2
jwt_decoder - 2.0.1 2.0.1
path - 1.9.0 1.9.0
rxdart - 0.27.7 0.27.7
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
web - 0.5.1 0.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.