ngpageloader 5.0.0 copy "ngpageloader: ^5.0.0" to clipboard
ngpageloader: ^5.0.0 copied to clipboard

Platformweb

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

2
likes
140/ 160
pub points
8%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

332 out of 408 API elements (81.4 %) have documentation comments.

Some symbols that are missing documentation: core, html.HtmlMouse.syncFn, html.HtmlPageLoaderElement.HtmlPageLoaderElement.createFromElement, html.HtmlPageLoaderElement.elements, html.HtmlPageLoaderElement.syncFn.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:ngpageloader/html.dart that imports:
  • package:ngpageloader/src/html/html_pointer.dart that imports:
  • package:ngpageloader/src/html/html_page_loader_element.dart that imports:
  • package:ngpageloader/src/html/html_page_utils.dart that imports:
  • package:ngpageloader/src/html/html_mouse.dart that imports:
  • dart:svg
Package not compatible with platform iOS

Because:

  • package:ngpageloader/html.dart that imports:
  • package:ngpageloader/src/html/html_pointer.dart that imports:
  • package:ngpageloader/src/html/html_page_loader_element.dart that imports:
  • package:ngpageloader/src/html/html_page_utils.dart that imports:
  • package:ngpageloader/src/html/html_mouse.dart that imports:
  • dart:svg
Package not compatible with platform Windows

Because:

  • package:ngpageloader/html.dart that imports:
  • package:ngpageloader/src/html/html_pointer.dart that imports:
  • package:ngpageloader/src/html/html_page_loader_element.dart that imports:
  • package:ngpageloader/src/html/html_page_utils.dart that imports:
  • package:ngpageloader/src/html/html_mouse.dart that imports:
  • dart:svg
Package not compatible with platform Linux

Because:

  • package:ngpageloader/html.dart that imports:
  • package:ngpageloader/src/html/html_pointer.dart that imports:
  • package:ngpageloader/src/html/html_page_loader_element.dart that imports:
  • package:ngpageloader/src/html/html_page_utils.dart that imports:
  • package:ngpageloader/src/html/html_mouse.dart that imports:
  • dart:svg
Package not compatible with platform macOS

Because:

  • package:ngpageloader/html.dart that imports:
  • package:ngpageloader/src/html/html_pointer.dart that imports:
  • package:ngpageloader/src/html/html_page_loader_element.dart that imports:
  • package:ngpageloader/src/html/html_page_utils.dart that imports:
  • package:ngpageloader/src/html/html_mouse.dart that imports:
  • dart:svg
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 49 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/html.dart:14:1

   ╷
14 │ /// Exports all APIs and classes needed for running in-browser.
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/html.dart

INFO: Dangling library doc comment.

lib/pageloader.dart:14:1

   ╷
14 │ /// Following is useful only for WebDriver Test Creator.
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/pageloader.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^4.1.0 4.7.0 6.7.0
build ^2.0.2 2.4.1 2.4.1
build_config ^1.0.0 1.1.1 1.1.1
built_value ^8.0.6 8.9.2 8.9.2
collection ^1.15.0 1.19.0 1.19.0
js ^0.6.3 0.6.7 0.7.1
matcher ^0.12.10 0.12.16+1 0.12.16+1
quiver ^3.0.1 3.2.1 3.2.1
source_gen ^1.0.1 1.2.6 1.5.0
webdriver ^3.0.0 3.0.3 3.0.3
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 47.0.0 72.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
checked_yaml - 2.0.3 2.0.3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.2.4 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
sync_http - 0.3.1 0.3.1
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.1.0` on analyzer does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
8%
popularity

Publisher

verified publisherangulardart.xyz

Supports the creation of page objects that can be shared between in-browser tests and WebDriver tests.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, build, build_config, built_value, collection, js, matcher, quiver, source_gen, webdriver

More

Packages that depend on ngpageloader