ngdart_cli 1.3.0 copy "ngdart_cli: ^1.3.0" to clipboard
ngdart_cli: ^1.3.0 copied to clipboard

A command-line tool for creating and managing AngularDart projects.

2
likes
140/ 160
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux
  • ✓ macOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/commands/create.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/templates/new_project.g.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ansicolor ^2.0.1 2.0.2 2.0.2
args ^2.3.1 2.5.0 2.5.0
build ^2.3.0 2.4.1 2.4.1
cli_util ^0.3.5 0.3.5 0.4.1
dart_style ^2.2.3 2.3.6 2.3.6
glob ^2.0.2 2.1.2 2.1.2
path ^1.8.2 1.9.0 1.9.0
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 72.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.7.0
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
logging - 1.2.0 1.2.0
macros - 0.1.0-main.0 0.1.2-main.4
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.5` on cli_util does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions cli_util to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
0%
popularity

Publisher

verified publisherangulardart.xyz

A command-line tool for creating and managing AngularDart projects.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ansicolor, args, build, cli_util, dart_style, glob, path, yaml

More

Packages that depend on ngdart_cli