network_services 0.0.2 copy "network_services: ^0.0.2" to clipboard
network_services: ^0.0.2 copied to clipboard

Flutter Network Services.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add network_services

With Flutter:

 $ flutter pub add network_services

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  network_services: ^0.0.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:network_services/apiServices/networkService/abstract_network_service.dart';
import 'package:network_services/apiServices/networkService/api_result.dart';
import 'package:network_services/apiServices/networkService/api_result.freezed.dart';
import 'package:network_services/apiServices/networkService/logging_interceptor.dart';
import 'package:network_services/apiServices/networkService/network_exceptions.dart';
import 'package:network_services/apiServices/networkService/network_exceptions.freezed.dart';
import 'package:network_services/apiServices/networkService/network_service.dart';
import 'package:network_services/flutter_apps.dart';
1
likes
0
pub points
34%
popularity

Publisher

unverified uploader

Flutter Network Services.

License

unknown (LICENSE)

Dependencies

dartz, dio, flutter, flutter_gen, freezed, freezed_annotation, get

More

Packages that depend on network_services