network_info_plus_linux 1.0.0
network_info_plus_linux: ^1.0.0 copied to clipboard

Linux implementation of the network_info_plus plugin

1
likes
90 / 130
pub points
78 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 3 API elements (100.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:network_info_plus_linux/network_info_plus_linux.dart that declares support for platforms: Linux
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dbus^0.2.10.2.50.4.0
flutterflutter0.0.00.0.0
meta^1.3.01.3.01.3.0
network_info_plus_platform_interface^1.0.01.0.01.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.0.02.0.0
characters-1.1.01.1.0
collection-1.15.01.15.0
petitparser-4.1.04.1.0
plugin_platform_interface-2.0.02.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
xml-5.1.05.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.1` on dbus does not support the stable version `0.3.0`, that was published 18 days ago.

When dbus is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dbus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.