nativeshell 0.1.16 copy "nativeshell: ^0.1.16" to clipboard
nativeshell: ^0.1.16 copied to clipboard

NativeShell Dart API. Used to interact with NativeShell platform code.

29
likes
90/ 140
pub points
61%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting nativeshell... Discovering libraries... Linking elements... Precaching local docs for 610557 elements... Initialized dartdoc with 772 libraries Generating docs for library nativeshell.dart from package:nativeshell/nativeshell.dart... Generating docs for library accelerators.dart from package:nativeshell/accelerators.dart... Documented 2 public libraries in 76.6 seconds ERR: warning: nativeshell has no library level documentation comments from nativeshell: (file:///tmp/pana_KMBGGZ/lib/nativeshell.dart:1:9) warning: nativeshell has no library level documentation comments from nativeshell: (file:///tmp/pana_KMBGGZ/lib/accelerators.dart:1:9) error: file already written at "nativeshell/nativeshell-library.html" for symbol nativeshell: (file:///tmp/pana_KMBGGZ/lib/accelerators.dart:1:9) conflicting with file already generated by nativeshell: (file:///tmp/pana_KMBGGZ/lib/nativeshell.dart:1:9) Dartdoc generates a path and filename to write to for each symbol. 'nativeshell' conflicts with another symbol in the generated path, and therefore can not be written out. Changing the name, library name, or [13 more lines]

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:nativeshell/nativeshell.dart that imports:
  • package:nativeshell/src/window.dart that imports:
  • package:nativeshell/src/window_widget.dart that imports:
  • package:nativeshell/src/window_manager.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 37 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/accelerator.dart:74:17

   ╷
74 │   bool operator ==(dynamic other) =>
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/accelerator.dart

WARNING: This API is available since SDK 2.14.0, but constraints '>=2.13.0 <3.0.0' don't guarantee it.

lib/src/accelerator.dart:84:30

   ╷
84 │   int get hashCode => Object.hash(alt, control, meta, shift, key);
   │                              ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/accelerator.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
pedantic ^1.9.2 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

29
likes
90
pub points
61%
popularity

Publisher

verified publishernativeshell.dev

NativeShell Dart API. Used to interact with NativeShell platform code.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, pedantic

More

Packages that depend on nativeshell