native_stack_traces 0.5.7 copy "native_stack_traces: ^0.5.7" to clipboard
native_stack_traces: ^0.5.7 copied to clipboard

Utilities for working with non-symbolic stack traces.

11
likes
120/ 140
pub points
100%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

55 out of 125 API elements (44.0 %) have documentation comments.

Some symbols that are missing documentation: elf, elf.DynamicTable.operator [], elf.DynamicTable.containsKey, elf.DynamicTable.fromReader, elf.DynamicTable.writeToStringBuffer.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:native_stack_traces/native_stack_traces.dart that imports:
  • package:native_stack_traces/src/dwarf.dart that imports:
  • package:native_stack_traces/src/reader.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.5.0 2.5.0
path ^1.8.0 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

11
likes
120
pub points
100%
popularity

Publisher

verified publishertools.dart.dev

Utilities for working with non-symbolic stack traces.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

args, path

More

Packages that depend on native_stack_traces