native_id 0.0.5 copy "native_id: ^0.0.5" to clipboard
native_id: ^0.0.5 copied to clipboard

Get unique identifier for android and iOS

2
likes
130/ 140
pub points
73%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/mixin27/flutter_native_id was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/mixin27/flutter_native_id/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 15 API elements (73.3 %) have documentation comments.

Some symbols that are missing documentation: native_id, native_id_method_channel, native_id_platform_interface, native_id_platform_interface.NativeIdPlatform.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:native_id/native_id.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:native_id/native_id.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:native_id/native_id.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:native_id/native_id.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

2
likes
130
pub points
73%
popularity
screenshot

Publisher

verified publishermixin27.blogspot.com

Get unique identifier for android and iOS

Repository (GitHub)
View/report issues

Topics

#imei #unique-identifier #utility

Documentation

API reference

Funding

Consider supporting this project:

www.buymeacoffee.com

License

MIT (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on native_id