nano 0.3.2 copy "nano: ^0.3.2" to clipboard
nano: ^0.3.2 copied to clipboard

Nano makes it easier to build and maintain complex Flutter apps.

2
likes
120/ 160
pub points
34%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

78 out of 159 API elements (49.1 %) have documentation comments.

Some symbols that are missing documentation: nano, nano.Action.clear, nano.Action.run, nano.ActionBody, nano.ActionId.token.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 49 issues. Showing the first 2:

WARNING: Duplicate import.

lib/src/state_manager.dart:9:8

  ╷
9 │ import 'utils.dart';
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/state_manager.dart

INFO: Use the generic function type syntax in 'typedef's.

lib/src/action.dart:5:19

  ╷
5 │ typedef Future<K> ActionBody<T, K>(T payload);
  │                   ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/action.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.12.0 1.15.0
rxdart ^0.27.2 0.27.7 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.

2
likes
120
pub points
34%
popularity

Publisher

verified publisherkibibyte.in

Nano makes it easier to build and maintain complex Flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, meta, rxdart

More

Packages that depend on nano