my_mvvm 0.0.2 copy "my_mvvm: ^0.0.2" to clipboard
my_mvvm: ^0.0.2 copied to clipboard

A new Flutter simplfy state management package

4
likes
130/ 160
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://hbosoftware.com/ was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

152 out of 226 API elements (67.3 %) have documentation comments.

Some symbols that are missing documentation: my_mvvm, my_mvvm.BoundList.binding, my_mvvm.BoundList.composer, my_mvvm.BuilderHelpers, my_mvvm.BuilderHelpers.disposed.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

WARNING: Unused import: 'package:provider/provider.dart'.

lib/my_mvvm.dart:8:8

  ╷
8 │ import 'package:provider/provider.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/my_mvvm.dart

INFO: Use the generic function type syntax in 'typedef's.

lib/src/sigma_types/type_def.dart:1:14

  ╷
1 │ typedef void ValueCallback<T>(T v);
  │              ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/sigma_types/type_def.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
provider ^6.0.4 6.1.2 6.1.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
130
pub points
0%
popularity

Publisher

unverified uploader

A new Flutter simplfy state management package

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter, provider

More

Packages that depend on my_mvvm