multiple_image_camera 0.0.2 copy "multiple_image_camera: ^0.0.2" to clipboard
multiple_image_camera: ^0.0.2 copied to clipboard

A Flutter package for both android and iOS which provides Take Multiple Images from Camera.

18
likes
130/ 160
pub points
85%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 20 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: camera_file, camera_file.CameraFile, camera_file.CameraFile.CameraFile, camera_file.CameraFile.customButton, camera_file.MediaModel.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:multiple_image_camera/multiple_image_camera.dart that imports:
  • package:multiple_image_camera/camera_file.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:multiple_image_camera/multiple_image_camera.dart that imports:
  • package:multiple_image_camera/camera_file.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:multiple_image_camera/multiple_image_camera.dart that imports:
  • package:multiple_image_camera/camera_file.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package not compatible with platform Web

Because:

  • package:multiple_image_camera/multiple_image_camera.dart that imports:
  • package:multiple_image_camera/camera_file.dart that imports:
  • package:multiple_image_camera/image_preview.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'background' is deprecated and shouldn't be used. Use surface instead. This feature was deprecated after v3.18.0-0.1.pre.

lib/camera_file.dart:362:54

    ╷
362 │       backgroundColor: Theme.of(context).colorScheme.background,
    │                                                      ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/camera_file.dart

lib/image_preview.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
camera ^0.10.5+6 0.10.6 0.11.0+1
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
camera_android - 0.10.9+8 0.10.9+8
camera_avfoundation - 0.9.17 0.9.17
camera_platform_interface - 2.8.0 2.8.0
camera_web - 0.3.4 0.3.4
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
stream_transform - 2.1.0 2.1.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.10.5+6` on camera does not support the stable version `0.11.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

18
likes
130
pub points
85%
popularity

Publisher

verified publishergoldeneagle.ai

A Flutter package for both android and iOS which provides Take Multiple Images from Camera.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

camera, flutter

More

Packages that depend on multiple_image_camera