multipack 0.1.3
multipack: ^0.1.3 copied to clipboard

A tool for monorepo management. Link local packages and execute commands in topological order.

Use this package as an executable

Install it

You can install the package from the command line:

dart pub global activate multipack

Use it

The package has the following executables:

$ multipack

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add multipack

With Flutter:

 $ flutter pub add multipack

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  multipack: ^0.1.3

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:multipack/commands.dart';
import 'package:multipack/commands/analyze.dart';
import 'package:multipack/commands/common.dart';
import 'package:multipack/commands/exec.dart';
import 'package:multipack/commands/fmt.dart';
import 'package:multipack/commands/pub.dart';
import 'package:multipack/commands/pubspec.dart';
import 'package:multipack/commands/pubspec/bump_alpha.dart';
import 'package:multipack/commands/pubspec/clean.dart';
import 'package:multipack/commands/pubspec/hard_override.dart';
import 'package:multipack/commands/pubspec/override.dart';
import 'package:multipack/commands/pubspec/sync_versions.dart';
import 'package:multipack/package.dart';
9
likes
70
pub points
0%
popularity

Publisher

gql-dart.dev

A tool for monorepo management. Link local packages and execute commands in topological order.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, args, directed_graph, meta, path, pub_semver, pubspec

More

Packages that depend on multipack