multi_screen_layout 3.1.0 copy "multi_screen_layout: ^3.1.0" to clipboard
multi_screen_layout: ^3.1.0 copied to clipboard

PlatformAndroid

A collection of Widgets that make multi screen user experiences easy to build

23
likes
120/ 140
pub points
51%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 41 API elements (61.0 %) have documentation comments.

Some symbols that are missing documentation: multi_screen_layout, multi_screen_layout.MasterDetailLayout.detail, multi_screen_layout.MasterDetailLayout.isSelected, multi_screen_layout.MasterDetailLayout.master, multi_screen_layout.MultiScreenInfo.builder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:multi_screen_layout/multi_screen_layout.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:multi_screen_layout/multi_screen_layout.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:multi_screen_layout/multi_screen_layout.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:multi_screen_layout/multi_screen_layout.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:multi_screen_layout/multi_screen_layout.dart that declares support for platforms: Android.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/src/ui/multi_screen_info.dart:25:28

   ╷
25 │     WidgetsBinding.instance?.addObserver(this);
   │                            ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/ui/multi_screen_info.dart

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/src/ui/multi_screen_info.dart:26:36

   ╷
26 │     info = (PageStorage.of(context)?.readState(
   │                                    ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/ui/multi_screen_info.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

23
likes
120
pub points
51%
popularity

Publisher

verified publisherjasonrai.ca

A collection of Widgets that make multi screen user experiences easy to build

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on multi_screen_layout