mp_chart 0.3.1
mp_chart: ^0.3.1 copied to clipboard

A Flutter chart package just like AndroidMPChart, apply easy to use chart for Flutter.

103
likes
90/ 130
pub points
87%
popularity

We analyzed this package 25 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 847 out of 2998 API elements (28.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

lib/mp/chart/bar_line_scatter_candle_bubble_chart.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/mp/chart/combined_chart.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
image_gallery_saver^1.2.21.7.11.7.1
intl^0.17.0-nullsafety.10.17.00.17.0
optimized_gesture_detector^0.0.60.0.60.0.6
path_drawing^0.4.10.4.1+11.0.0
path_provider^1.1.01.6.282.0.7
screenshot^0.1.10.1.11.2.3
vector_math^2.0.82.1.02.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
path_parsing-0.1.41.0.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.4
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.4.1` on path_drawing does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions path_drawing to update the constraint.

The constraint `^1.1.0` on path_provider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

103
likes
90
pub points
87%
popularity

A Flutter chart package just like AndroidMPChart, apply easy to use chart for Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, image_gallery_saver, intl, optimized_gesture_detector, path_drawing, path_provider, screenshot, vector_math

More

Packages that depend on mp_chart