month_picker_dialog 0.0.8

month_picker_dialog #

Build Status pub package

Internationalized material style dialog for picking a single month from an infinite list of years. This package makes use of the intl package and flutter's i18n abilities to provide labels in all languages known to flutter.

Setting up an internationalized app: the flutter localization package

Screenshots #

Left-To-Right #

LTR portrait LTR landscape

Right-To-Left #

RTL portrait RTL landscape

0.0.5 #

  • provided screenshots to README

0.0.6 #

  • renamed docs to screenshots to appease to pub

0.0.8 #

  • refactoring and removal of white border

example/README.md

month_picker_dialog_example #

Demonstrates how to use the month_picker_dialog package.

Screenshots #

Left-To-Right #

LTR portrait LTR landscape

Right-To-Left #

RTL portrait RTL landscape

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  month_picker_dialog: ^0.0.8

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:month_picker_dialog/month_picker_dialog.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
87
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
91
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/month_picker_dialog.dart. (-0.50 points)

Analysis of lib/month_picker_dialog.dart reported 1 hint:

line 5 col 1: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_localizations 0.0.0
intl ^0.15.7 0.15.8
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8

Admin