mono_repo 3.0.0
mono_repo: ^3.0.0
mono_repo: ^3.1.0-beta.4

Dart native
Flutter Android iOS

CLI tools to make it easier to manage a single source repository containing multiple Dart packages.

9
likes
75 / 110
pub points
23 %
popularity

We analyzed this package on Nov 21, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be well formed Unable to parse 1 image link.

README.md:8:20

  ╷
8 │ <p>Or, once you've <a href="(https://dart.dev/tools/pub/cmd/pub-global#running-a-script-from-your-path)">setup your PATH</a>:</p>
  │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 7 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:mono_repo/mono_repo.dart that imports:
  • package:mono_repo/src/runner.dart that imports:
  • package:mono_repo/src/commands/travis.dart that imports:
  • package:mono_repo/src/commands/travis/travis_yaml.dart that imports:
  • package:mono_repo/src/yaml.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.4.01.6.01.6.0
checked_yaml^1.0.01.0.21.0.2
collection^1.14.31.14.131.14.13
graphs^0.2.00.2.00.2.0
io^0.3.2+10.3.40.3.4
json_annotation^3.0.03.1.13.1.1
meta^1.0.01.2.41.2.4
path^1.4.11.7.01.7.0
pub_semver^1.3.21.4.41.4.4
pubspec_parse^0.1.00.1.50.1.5
yaml^2.1.122.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
75
pub points
23%
popularity

Publisher

google.dev

CLI tools to make it easier to manage a single source repository containing multiple Dart packages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

args, checked_yaml, collection, graphs, io, json_annotation, meta, path, pub_semver, pubspec_parse, yaml

More

Packages that depend on mono_repo