modest_pagination 0.0.1+1 copy "modest_pagination: ^0.0.1+1" to clipboard
modest_pagination: ^0.0.1+1 copied to clipboard

Attempt at modularizing my own pagination. It is a simple to use pagination component (that most suites my needs and may fit into your needs too)

4
likes
140/ 160
pub points
42%
popularity

We analyzed this package 5 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 21 API elements (85.7 %) have documentation comments.

Some symbols that are missing documentation: modest_pagination, modest_pagination.ModestPagination, modest_pagination.ModestPagination.ModestPagination.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Unnecessary cast.

lib/src/pagination.dart:117:9

    ╷
117 │         widget.items.partition(chunkSize: widget.itemsPerPage) as List<List<T>>;
    │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/pagination.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
handy_extensions ^0.0.5 0.0.9 0.2.5
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.5` on handy_extensions does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions handy_extensions to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

4
likes
140
pub points
42%
popularity

Publisher

verified publisheriamngoni.co.zw

Attempt at modularizing my own pagination. It is a simple to use pagination component (that most suites my needs and may fit into your needs too)

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, handy_extensions

More

Packages that depend on modest_pagination