miot_spec 0.6.0 copy "miot_spec: ^0.6.0" to clipboard
miot_spec: ^0.6.0 copied to clipboard

Dart implementation of MIoT specification.

0
likes
70/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

11 out of 92 API elements (12.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: miot_spec, miot_spec.InstanceActionSpec, miot_spec.InstanceActionSpec.InstanceActionSpec, miot_spec.InstanceActionSpec.description, miot_spec.InstanceActionSpec.InstanceActionSpec.fromJson.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/type.dart:44:18

   ╷
44 │         (e) => e.name == list[2],
   │                  ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/type.dart

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/type.dart:84:47

   ╷
84 │   String toString() => 'urn:$namespace:${type.name}:$name'
   │                                               ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/type.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.5.0 2.5.0
dio ^4.0.0 4.0.6 5.4.3+1
json_annotation ^4.6.0 4.9.0 4.9.0
logger ^1.0.0 1.4.0 2.3.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^1.0.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

0
likes
70
pub points
0%
popularity

Publisher

verified publisherxdea.io

Dart implementation of MIoT specification.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

args, dio, json_annotation, logger

More

Packages that depend on miot_spec