midtrans_helper 0.0.1+5 icon indicating copy to clipboard operation
midtrans_helper: ^0.0.1+5 copied to clipboard

Midtrans Easy To Add

2
likes
80/ 140
pub points
0%
popularity

We analyzed this package 16 hours ago, and awarded it 80 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/hunterscript/midtrans_helper_flutter was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 85 API elements (30.6 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:midtrans_helper/midtrans_helper.dart that imports:
  • package:midtrans_helper/midtrans_pay.dart that imports:
  • package:request_api_helper/request_api_helper.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:midtrans_helper/midtrans_helper.dart that imports:
  • package:midtrans_helper/midtrans_pay.dart that imports:
  • package:request_api_helper/request_api_helper.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:midtrans_helper/midtrans_helper.dart that imports:
  • package:midtrans_helper/midtrans_pay.dart that imports:
  • package:request_api_helper/request_api_helper.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:midtrans_helper/midtrans_helper.dart that imports:
  • package:midtrans_helper/midtrans_pay.dart that imports:
  • package:midtrans_helper/qr_code.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image/src/image_provider/_image_provider_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

INFO: Unused import: 'package:midtrans_helper/qr_code.dart'.

lib/midtrans_pay.dart:5:8

  ╷
5 │ import 'package:midtrans_helper/qr_code.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/midtrans_pay.dart

INFO: Unused import: 'package:cached_network_image/cached_network_image.dart'.

lib/midtrans_va.dart:1:8

  ╷
1 │ import 'package:cached_network_image/cached_network_image.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/midtrans_va.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^2.3.2+12.5.13.2.3
flutterflutter0.0.00.0.0
intl^0.15.70.15.80.18.0
request_api_helper^2.2.32.2.6+104.0.5+1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.63.3.6
async-2.10.02.10.0
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.17.01.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_blurhash-0.5.00.7.0
flutter_cache_manager-2.1.23.3.0
flutter_web_plugins-0.0.00.0.0
fluttertoast-8.1.28.1.2
http-0.13.50.13.5
http_parser-4.0.24.0.2
image-3.3.04.0.13
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
octo_image-0.3.01.0.2
path-1.8.31.8.3
path_provider-2.0.122.0.12
path_provider_android-2.0.222.0.22
path_provider_foundation-2.1.12.1.1
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
pedantic-1.11.11.11.1
petitparser-5.1.05.1.0
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
pointycastle-3.6.23.6.2
process-4.2.44.2.4
rxdart-0.25.00.27.7
shared_preferences-2.0.172.0.17
shared_preferences_android-2.0.152.0.15
shared_preferences_foundation-2.1.32.1.3
shared_preferences_linux-2.1.32.1.3
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
sqflite-2.2.4+12.2.4+1
sqflite_common-2.4.2+22.4.2+2
string_scanner-1.2.01.2.0
synchronized-3.0.13.0.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
vector_math-2.1.42.1.4
win32-3.1.34.1.1
xdg_directories-0.2.0+30.2.0+3
xml-6.2.26.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.3.2+1` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.15.7` on intl does not support the stable version `0.16.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

2
likes
80
pub points
0%
popularity

Publisher

unverified uploader

Midtrans Easy To Add

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

cached_network_image, flutter, intl, request_api_helper

More

Packages that depend on midtrans_helper