metrics_center 1.0.13 copy "metrics_center: ^1.0.13" to clipboard
metrics_center: ^1.0.13 copied to clipboard

Support multiple performance metrics sources/formats and destinations.

0
likes
120/ 140
pub points
99%
popularity

We analyzed this package 45 hours ago, and awarded it 120 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+metrics_center%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

52 out of 53 API elements (98.1 %) have documentation comments.

Some symbols that are missing documentation: metrics_center.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:metrics_center/metrics_center.dart that imports:
  • package:metrics_center/src/skiaperf.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/authorization_code_grant_server_flow.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
_discoveryapis_commons ^1.0.0 1.0.6 1.0.6
crypto ^3.0.1 3.0.3 3.0.3
gcloud ^0.8.2 0.8.12 0.8.12
googleapis ^12.0.0 12.0.0 13.1.0
googleapis_auth ^1.1.0 1.6.0 1.6.0
http >=0.13.0 <2.0.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
google_identity_services_web - 0.3.1+1 0.3.1+1
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
retry - 3.1.2 3.1.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^12.0.0` on googleapis does not support the stable version `13.0.0`.

Try running dart pub upgrade --major-versions googleapis to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
120
pub points
99%
popularity

Publisher

verified publisherflutter.dev

Support multiple performance metrics sources/formats and destinations.

Repository (GitHub)
View/report issues
Contributing

Topics

#ci #metrics

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

_discoveryapis_commons, crypto, gcloud, googleapis, googleapis_auth, http

More

Packages that depend on metrics_center