material_x 0.6.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 85

material-x

Getting Started Material_X: #

Good news to all Flutter Developers .

All the developers, now you can develop more faster and better then before with new feature use Material_X package to be more productive and more fast to build any platform application.

Now, you can get more by writing less "Material_X"

Installation #

First, add material_x: as a dependency in your pubspec.yaml file.

Import

dart import 'package:material_x/material_x.dart';

Example #

carbon (1)

Material_X VS Code Extension: #

Get this extension & get more feature from Material_X

Open VS Code -> Go to extensions -> Search 'Material-X' #

Get alots of shortcut features with its snippet features with More shortcut feature

Material-X Extension

Note: Material-X is not directly and/or indirectly associated/affiliated with Flutter or Google LLC.

Copyright-and-license #

Code and documentation Copyright 2020 Zeeshux7860. Code released under the Apache License. Docs released under Creative Commons.

[0.5.2] - TODO: Add release date. #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:material_x/material_x.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return HomePage().mxMaterialApp();
  }
}

class HomePage extends StatefulWidget {
  @override
  _HomePageState createState() => _HomePageState();
}

class _HomePageState extends State<HomePage> {
  @override
  Widget build(BuildContext context) {
    return mxListView.list([
      ["one", "two", "three"].mxDropdownLabel(
          name: "zeshan",
          onChanged: (v) {
            setState(() {});
          },
          dropdownValue: "two"),
    ]).mxScaffold(appBar: "example Dropdown".text().mxAppBar());
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  material_x: ^0.6.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:material_x/material_x.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
70
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
85
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • material_x that is a package requiring null.

Package not compatible with runtime flutter-web on Web

Because:

  • package:material_x/material_x.dart that imports:
  • package:material_x/src/Extension/Strings.dart that imports:
  • dart:io

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
animated_interpolation ^0.3.2 0.3.2
console_cmd ^1.0.5 1.0.5
dart_style ^1.3.4 1.3.6
flutter 0.0.0
flutter_widgets ^0.1.12 0.1.12
json_ast ^1.0.5 1.0.5
process_run ^0.10.10+1 0.10.10+2
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
args 1.6.0
async 2.4.2
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
grapheme_splitter 1.0.0
html 0.14.0+3
io 0.3.4
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.2
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pedantic 1.9.0 1.9.2
pub_semver 1.4.4
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
flutter_test