flutter_widgets 0.1.6

Flutter widgets #

Build Status

This repository contains the source code for various Flutter widgets that are developed by Google but not by the core Flutter team.

The Gallery sample application showcases the included Flutter widgets. To build it, first create the default Flutter project files:

cd gallery
flutter create .

and then it can be run with flutter run.

Issues #

Please file any issues, bugs, or feature requests in the this repo.

Contributing #

If you wish to contribute a change to any of the existing widgets in this repo, please review our contribution guide, and send a pull request.

0.1.6 #

  • Added ScrollablePositionedList.
  • Fixed an incompatibility in VisibilityDetector with Flutter 1.9.1 (issue #20).
  • Removed dependency on package:intl.

0.1.5 #

  • Clarified authors in pubspec.yaml.

  • Fixed lint violations of prefer_collection_literals.

  • Adjust the minimum versions of dependencies.

0.1.4 #

  • VisibilityDetector:

    • Fixed positioning of text selection handles for EditableText-based widgets (e.g. TextField, CupertinoTextField) when used within a VisibilityDetector.

    • Added VisibilityDetectorController.widgetBoundsFor.

0.1.3 #

  • Compatibility fixes for Flutter 1.3.0.

0.1.2 #

  • Added VisibilityDetectorController.forget.

0.1.1 #

  • Add LinkedScrollContainer and VisibilityDetector widgets.

0.1.0 #

Initial release featuring:

  • html_widget: Limited support for rendering HTML as flutter widgets. currently supports the following tags: div, br, table, b, u, a, font, hr, text

  • tagged_text: Support for styling text using custom HTML-like tags. This is particularly useful for styling text within a translated string.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_widgets: ^0.1.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_widgets/flutter_widgets.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
92
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
94
Learn more about scoring.

We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_widgets.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
collection ^1.14.5 1.14.11 1.14.12
flutter 0.0.0
html ^0.14.0 0.14.0+2
meta ^1.1.1 1.1.7
quiver ^2.0.0+1 2.0.5
Transitive dependencies
charcode 1.1.2
csslib 0.16.1
matcher 0.12.5
path 1.6.4
sky_engine 0.0.99
source_span 1.5.5
stack_trace 1.9.3
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^3.0.0
pedantic ^1.8.0
test ^1.3.0